View Single Post
      06-15-2012, 12:36 AM   #1
radiantm3
Apex Everything!
radiantm3's Avatar
United_States
159
Rep
3,880
Posts

 
Drives: >1000 HP in my garage
Join Date: Sep 2008
Location: Danville, CA

iTrader: (6)

Garage List
2011 E92 M3  [4.80]
2013 BMW X5M  [4.33]
2014 BMW i3  [0.00]
My Cantrell Motorsports Brake Duct Kit writeup (with BBK)

So I installed this kit today and figured I'd share my experience with it since I have a slightly different setup than stock. Some of you might be wondering why bother with brake ducting when I have a BBK already? Well my front pads are wearing extremely fast and I'm hoping a bit of cooling might preserve a bit more life in them. I also have the challenge gt3 diffuser which has brake ducting built in so why not make use of them.

Challenge GT3 diffuser with brake duct inlets in the front.



Brakes and rotors off. Backing plate fitment is good. It requires 2 spacers between the provided bolts for the bottom 2 mounting points.



As you can see, there's plenty of room for the BBK.



Another view from above. You can see the 3 mounting points.



Hose attached. The Cantrell kit is all 2.5" ducting and the Challenge diffuser happened to be 3". I was worried at first, but the hose fits snug enough on the inside of the diffuser duct so I just fed about 3" of hose into it without tying it down. It definitely won't come out with that bottom zip tie in place. You can also see some duct tape I put on parts of the hose where I thought it might rub. Just an extra precaution.



Here's a shot with the wheel well back in. I had to cut a small part of it to fit around the hose.



Brakes are back on.



Here's a top view so you can see how close the backing plate is to the rotor. The air hits the inside center area of the rotor.



A shot from the front under carriage so you can see where the diffuser ducting ends and the hose enters.



Here's a view from under with the wheels on and pointing straight ahead.



[b]And here's a view with the wheel at full lock. You can see the tire slightly rubbing on the hose. At just slightly less than full lock, it doesn't rub so I think as long as I pay attention it shouldn't be an issue at all. If I do rub too often, my first solution will be to flatten the hose a bit where it does rub. The hose is structured with some pretty strong metal wire so I can make part of the hose into more of an oval shape. Hopefully that will fix it.



So does it work?

I drove around town today with only one side setup and did a couple moderately hard stops as well as driving at around 45 mph. The rotor with the brake cooling was about 10-15 degrees cooler than the side without cooling. I checked the rotor temps on 2 occasions with an infrared temp gauge and the results were pretty much the same.

I'm heading out to Laguna Seca again this Sunday so I'll be recording more relevant data. I recorded front rotor temps last month at the same track so I'll have hard numbers to compare. Stay tuned.