View Single Post
      05-25-2012, 09:56 PM   #1
Prince_of_Persia
Colonel
 
Prince_of_Persia's Avatar
 
Drives: 6MT E92 M3
Join Date: Aug 2010
Location: Vancouver, BC

Posts: 2,377
iTrader: (1)

Unhappy Got Every Single Possible Error and then Limp Mode.

So on last Wednesday, I was driving my car when I got all kinds of errors on my iDrive (attached pictures). Restarted my car few times and still same error. iDrive was saying it is safe to drive the car, so drove my car to the dealership. Let me tell you something, it is extremely hard to drive an M3 when it has reduced power (limited to 4K RPM). Dealership called yesterday and they told me it was the Throttle Actuator, but BMW Canada doesn't allow them to change the parts right away before updating the software in my car to make sure it was not a software issue.

So they updated the software in my car and called and told me it is ready to pick up. Picked my car this afternoon to just drive it to home and get all the same errors again. Called the dealership and they advised me to take my car back to the dealership so they can test it again. They mentioned they might have to replace the Throttle actuator and the DMU as well.

I hope they can fix it soon!! We have a BMW cruise in a week!!

P.S. This is the first time I have had problem with my car. The car has around 55,000 KM on it and has 2 more months warranty left (and then 2 years of CPO warranty).

Any one else had all these errors at the same time?

These are the errors:












Last edited by Prince_of_Persia; 05-25-2012 at 10:26 PM.
Prince_of_Persia is offline   Canada
0
Reply With Quote