View Single Post
      05-18-2012, 03:23 AM   #80
M3garage
Private
 
Drives: 2011 M3 coupe
Join Date: Feb 2011
Location: new jersey

Posts: 78
iTrader: (2)

Quote:
Originally Posted by shake&bake View Post
Replaced the front OEM springs with Eibach Performance springs on Friday. Started with the front with the plans of replacing the rear springs later this week. I used the very helpful DIY instructions available on the forum and everything seemed to go OK. Here are my questions:

1.When swapping out the springs, did anyone replace the swaybar or strut lock nuts with new hardware? I just reused them, but am questioning if I needed new.

2.If I like the ride and look of the car with the Eibach springs in the front and the OEM springs in the back, is there a compelling reason to change out the rear shocks with the Eibach? I have 20" CH-R in 255/30/20, and 285/30/20 in the rear. 3mm chamber plat coming for the front. The car currently has an even stance and I'm worried if I drop the rear it will be too much for the 30 profile tires.

3.Dove the car home on Friday after the front install with no errors. Washed the car over the weekend and when I started it today there was a EDC error. I checked all the connectors and the wiring harness and everything seems ok. Any ideas?

Thanks for the help.
I have the same problem. Edc error. Did you find out what the problem was? I tried everything, might have to take it to the dealer. Any info would be appreciated.
M3garage is offline   United_States
0
Reply With Quote