View Single Post
      05-04-2012, 11:27 PM   #1
atyps
New Member
 
Drives: 2011 E92 M3 Jet Black
Join Date: Jun 2011
Location: sac

Posts: 24
iTrader: (0)

Angry Please help, front tires rub!

So I got my dpe wheels after 6 months wait (don't ask)! Purchased in 11/2011, never received any update or pictures of the progress from dpe.

The wheels finally came in 4 generic dpe boxes with no specs or paper info. The wheels measured front 20X8.5 and rear 20X10.5 don't know the offset but it is suppose to be specific for e92 m3... dpe kept saying it's custom wheels so that's why it took so long to make...


i thought i was getting 20X9 for the front and that is probably why it rubs in the front because the tire isn't stretched out enough.

I purchased the hankook ventus v12 tires, dpe said these tires should fit
front 255/30/20
rear 295/25/20

the rears are a good fit and overall all the wheels look very nice but i'm that after 6 months I'm still trying to get wheels on the car...








i am lowered on

http://www.m3post.com/forums/showthr...ing+Sleeve+Kit

i have already ordered 2 more hankook ventus v12 in 245/30/20, hoping this will solve the rubbing. the tech at the shop didn't think getting spacers or adjusting the kw springs would solve the rubbing. i forgot to ask about camber though. anyone got recommendations? TIA

p.s. I also didn't know I would need tire pressure monitor kits in order to put the TPMS from the stock wheels into the new wheels... more headache... anyone one know where to buy some?
atyps is offline  
0
Reply With Quote