View Single Post
      01-08-2012, 02:56 PM   #39
Mike Benvo
BimmerPost Supporting Vendor

 
Mike Benvo's Avatar
 
Drives: 08 E90 M3 / 400whp Turbo 7
Join Date: Apr 2008
Location: SoCal

Posts: 4,570
iTrader: (7)

Garage List
1990 BMW 735i Turbo  [5.00]
2004 BMW M3  [0.00]
2008 BMW M3  [5.00]
Send a message via Skype™ to Mike Benvo
Quote:
Originally Posted by 540gone View Post
What I don't understand from the OP is there is no mention of whether he ordered his Evolve tune with the "CEL turned off" option selected or not? With the Challenge street pipe with secondary cat delete, the OE primary cats remain in place and the O2 sensors should operate just fine with no need for that tune option in the first place.

If that is the case, sounds like the issue might be somewhere else - like a bad O2 sensor. If his tune has that option, he should (as Mike suggests) simply ask Evolve for the tune with the CEL delete option not in place.

Maybe I'm missing something, but I don't understand why it's so critical to get it done on the weekend, it's just an inspection, and there was no mention of the car not running just fine.

I'll be interested so hear the resolution.
Very good point. With the primary cats in place, the CEL is likely to be some other fault other than cat efficiency.
__________________

-----| Like us on Facebook | Instagram || Tuning Information | Remote Coding |-----
----Visit us at www.BPMSport.com - Emotion. Driven. | Toll Free: (888) 557-5133----
Mike Benvo is offline   United_States
0
Reply With Quote